„Element wurde nicht gefunden“ – Ordner-Problem in Windows 7 beheben

Folgendes Phänomen:
Die Fehlermeldung „Element wurde nicht gefunden“ wird bei jeder Ordneraktion (Erstellen, Löschen, Verschieben, Umbenennen) angezeigt. Der Ordner existiert natürlich. Nach einem Klick auf „Wiederholen“ wird die Aktion fehlerfrei durchgeführt.

Dieses Problem bekam ich vor kurzer Zeit an meinem privaten PC. 1, 2 Wochen später das Selbe auf Arbeit.
Zeit eine Lösung zu finden. Und die fand ich im Antary Blog von Tobias (btw: Lesetipp). Er hatte das Problem ebenfalls und hat eine Lösung im Netz gefunden, einen Registry Fix:

Schritt 1:
Registry Fix (KB980408_fix.reg) herunterladen und per Doppelklick anwenden

Download section
KB980408_fix [.reg]

Registry Key anwenden, PC neustarten und das Problem ist behoben.

Sollte das doch noch nicht reichen gäbe es hier noch eine Lösung, die aber nicht mehr so richtig zu funktionieren scheint:
Wer Windows Updates automatisch bezieht kann meistens Schritt 1 überspringen, da das Update auf aktuellen Windows 7 PCs schon installiert ist. Wer auf Nummer Sicher gehen möchte,
Schritt 2:
Update KB 980408 installieren (x86, x64)

Über den Ursprung kann man nur Rätseln. Tobias vermutet, dass der nur Fehler auftritt, wenn man Bibliotheken Explorer Tweaks angewendet hat. Z.B. die Bibliotheken aus dem Dateibrowser entfernen, nicht anzeigen lassen o.Ä.
Da ich diese Tweaks sowohl zu Hause als auch auf Arbeit durchgeführt habe, könnte da was dran sein.

31 Kommentare

  1. Hallo,
    also der Fehler taucht auch dann auf, wenn keinerlei Tweaks angewendet wurden. Ich habe hier einen Win7-Rechner, der nun monatelang problemlos lief, doch seit heute kommt plötzlich dieser Fehler – ich vermute seit dem letzten WindowsUpdate, da ich sonst nicht wirklich Software installiere. Also kann über den Ursprung weiter gerätselt werden.

    Gruß
    DerRoteBaron

  2. Ich hab das Problem auch wieder seit paar Tagen oder Wochen an meinem Home PC, weiß nicht genau wann es wieder anfing. Aber getweaked habe ich nichts.
    Also ich vermute, dass vielleicht bestimmte Kombinationen von installierter Software und ausgelieferten Windows Updates zu dem Fehler führen. Müsste man gleich beim 1. Mal auftreten schauen ob kurz vorher Updates installiert wurden.
    Habe den Fix erneut angewandt und warte aufs nächste Mal 🙂

  3. Der Fehler taucht auf, wenn die Bibliotheken ausgeblendet werden (siehe unten). Mit der Lösung oben wird das Problem behoben. Wenn nun die Bibliotheken wieder eingeblendet werden (z.B. durch ein Windowsupdate) tritt das Problem wieder auf. Sobald die Bibliotheken wieder ausgeblendet sind ist auch der Fehler wieder weg!

    Im Windows Explorer ausblenden
    Den folgenden Registry Schlüssel löschen:
    HKEY_LOCAL_MACHINE\SOFWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace\{031E4825-7B94-4dc3-B131-E946B44C8DD5}

    Im Öffnen / Speichern Dialog ausblenden
    Den folgenden Registry Schlüssel löschen:
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\explore r\Desktop\NameSpace\{031E4825-7B94-4dc3-B131-E946B44C8DD5}

  4. Ich werde am nächsten PC, wo das Problem auftritt, diese Reglösung probieren. Falls sie funktioniert stelle ich eine Regdatei mit den Änderungen hier zum Download.
    Aber echt blöd, dass das Problem durch Windows Updates immer wieder hervorgerufen wird. Oder ist das durch das Löschen der 2 Keys für immer behoben?

  5. Hallo ich heiße Benedikt und habe folgendes Problem. Es ist verdammt nochmal NICHT natürlich, dass der Ordner oder das Element noch da ist. Ich habe einen Ordner von Camtasia einen Klon vom original, darin ist ein Unterordner und diesen kann ich nicht löschen, weil mir von etwa 10 Programmen gesagt wurde, dass es die Datei nicht gibt, ich habe soviel ausprobiert, kann mir jemand helfen, bei eineem Ordner der nicht mehr da ist, aber der BILDLICH noch zu sehen ist???

  6. Hi Leute ich habe das selbe Problem mit einem Backup-Ordner auf einer systemfremden Partition (Laufwerk D) Auch nach einem Format C blieb der Fehler bestehen. WIe kann er also mit Updates zusammenhängen? Daten speichere ich zwecks der Datensicherheit immer auf der Systemfremden Partition, mit Blibliotheken habe ich also noch nie etwas am Hut gehabt? Ich habe Win7 Ultimate OEM x64.

    Könnte mir jemand helfen?

    Mit freundlichen Grüßen.

  7. Also bisher hatte ich vermutet, dass die Fehlergrundlage durch Änderungen am Explorer verursacht wird ein Windows Updates den beschriebenen Fehler dann auslösen. Das passiert hin und wieder, also verschiedenste Updates scheinen den Fehler hin und wieder zu aktivieren.
    Aber das widerspricht natürlich deinem Fall.

    Also keine schlauen Ideen von mir, sorry.

  8. Hab das auch seit heute? W7 Pro, 64bit… Wenn ich das Update KB 980408 für 64bit runterlade und starte, bekomme ich die Meldung „Das Update ist nicht für Ihren Computer geeignet“ Und nun?

  9. Pingback: Anonymous
  10. Habe seit WIn 7 Prof 64 bit INstallation auf XP prof das obige Problem. Wollte gerade Update 980408 installieren und bekommen die gleich Meldung wie Mike!

  11. Danke Mike! 🙂

    Ich komme leider nicht umhin zu bemerken, dass viele anscheinend den Satz „Wer Windows Updates automatisch bezieht kann meistens Schritt 1 überspringen, da das Update auf aktuellen Windows 7 PCs schon installiert ist.“ irgendwie überlesen und die Reg Datei, die ich als Schritt 2 anbot, gar nicht erst ausprobieren sondern direkt hier kommentieren.

    Ich habe daher den Post jetzt umstrukturiert, biete direkt als Schritt 1 die Reg datei an (welche die selbe ist wie die von antary.de) und hoffe, dass die Leser jetzt schneller zur Lösung gelangen.

    Aber manchmal ist man im Vorteil wenn man 1. lesen kann und 2. erst alle angebotenen Tipps probiert und dann meckert.

    LG

  12. @Hannes: Deine Reg.-Datei ging bei MIR nicht 3x versucht, 3x PC Neu gestartet, negativ! Die in meinem Link angegebene Reg.-Datei 1x angewandt und funktionierte auf Anhieb! Wieso frag mich was leichteres!

  13. Seltsam, es ist eigentlich nur eine Kopie.
    Da der Fehler sogar an meinem PC gerade aktiv ist (ich hab mittlerweile gelernt ihn zu ignorieren weil er alle halbe Jahre eh wiederkommt xD) kann ich das ja direkt mal testen.

  14. @Hannes: Ja teste mal bitte, ich hatte diese Fehlermeldung bislang auch schon 2x, da ich viel Verschiebe, lösche war die Meldung für mich nervig.

  15. Jap, Problem behoben. Reg importiert und Neustart.
    Ich hab auch nochmal in die Reg geguckt, da gibt es auch keine 32bit/64bit Unterscheidung; hätte gedacht, dass das vielleicht der Grund ist warum es bei einigen nicht funktioniert.
    Also ehrlich gesagt: keine Ahnung…
    Aber wenn bei dir der Reg Key von antary.de läuft dann nimmst halt den ^^
    Hauptsache du kriegst das Problem weg.

  16. Lieber Hannes-
    vielen Dank! Mein Post sollte kein Meckern sein. „Wer Windows Updates automatisch bezieht kann meistens Schritt 1 überspringen, da das Update auf aktuellen Windows 7 PCs schon installiert ist.“ Habe wegen des „meistens“ Schritt 1 eben doch zunächst probiert und war irritiert über die Meldung, das sei Update sei für meinen PC nicht geeignet. Hätte erwartet, es kommt was wie : “ Bereits installiert“ oder so. Aber man sollte von Microsoft auch nicht zu viel erwarten.
    In jedem Fall vielen Dank.
    Werde die Reg versuchen.

    Andreas

  17. Hallo zusammen,

    habe den Link
    „http://www.antary.de/2010/05/11/windows-7-fehler-element-wurde-nicht-gefunden/“ verwendet. Funktioniert einwandfrei! Hatte mich Monate lang mit dem Problem geärgert. Vielen Dank euch!

  18. Hallo, wollte nur berechten das die *.reg das prob sofort gelöst hat! vielen dank dafür!
    mein prob war das ich TV aufnahmen im Ordner Videos abgelegt hatte .. die auf einmal nicht mehr auf der platte waren aber wohl im Explorer .. unter Linux hat es mir die Datei auch nicht angezeigt .. physisch waren die also weg .. der MS Patch war schon drauf!

  19. Pingback: Anonymous
  20. Hallo zusammen,
    und das Problem tritt immer wieder auf … Bei mir win7 Enterprise aktuell auf einer 4TB HDD über USB 3: (leerer) Ordner lässt sich nicht verschieben/löschen (Fehlermeldung: wie ober im Hardcopy). Anfänglich wollte ich den gesamten Ordner verschieben, bekam diese Meldung, dann habe ich auf der anderen HDD einen Ordner angelegt, den gesamten Inhalt verschoben, aber der leere Ordner lässt sich nicht löschen, auch nicht mit Administrator-Rechten.
    Ich habe die von Euch genannten *.reg ausgeführt, leider keinen Erfolg damit. Ich habe keine Bibliotheken-Tweaks benutzt, ich kann das MS-Hotfix nicht ausführen …
    Hat noch jemand neue Erkenntnisse?
    Viele Grüße, Reinhardt

  21. Hallo zusammen,
    ich habe noch ein Phänomen erkannt: die meisten dieser Ordner, die ich nicht löschen/verschieben kann, werden im WinExplorer in der Ordner Ansicht auch nicht mit dem Ordner-Symbol, sondern mit einer weißen Seite angezeigt, klickt man auf Eigenschaften, dann sind die Ordner vom Typ „Datei“, Größe 0 Bytes …
    Versteht jemand, wie das sein kann?
    (HDD WD 4 TB, NTFS, 2 Monate alt, Treiber neu …).
    Gruß, Reinhardt

  22. Hallo zusammen,
    ich habe noch etwas herausgefunden: die meisten der Ordner, die ich nicht löschen kann, stammen von einem Freund, der diese auf einem MacOS gespeichert hat. Kann man da ggf. mit einem Editor irgendein Byte im Header verändern?
    Viele Grüße,
    Reinhardt

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.