Excel: Dynamisch eingefärbte Diagrammbalken je nach Werten

excel-diagramme-farblich-gestalten-nach-werten-beispiel-diagramm-teaser

Einleitung

excel-diagramme-farblich-gestalten-nach-werten-zellgestaltungEs ist eine uralte Tradition: Farben zur Verdeutlichung oder zur Unterstützung einsetzen, beispielsweise um Werte implizit mit Bewertung zu versehen. Rote Werte sind häufig negativ, sprechen für fehlerhafte oder kritische Werte; Grün hat oft eine positive Bedeutung.
In Excel können solche farbigen Hervorhebungen bei Hunderten von Zahlwerten die Übersicht erleichtern und Kopfschmerzen reduzieren 😉 Dank der Funktion „Bedingter Formatierung“ und ihren vielen vordefinierten Regeln ist es auch super einfach, Zahlwerte mit Farben, Icons und Balken zu verdeutlichen.

Was ist nun aber mit Diagrammen, vor allem Balkendiagrammen? Dort wäre eine Einfärbung abhängig von zugrundliegenden Werten ebenfalls sinnvoll:
excel-diagramme-farblich-gestalten-nach-werten-beispiel-diagramm
Von Hause aus bietet Excel keine werteabhängigen Farbbalken in Diagrammen an. Also wird getrickst:

Vorbereitung der Werte

Die gewünschten Werte müssen zuerst über eine Hilfstabelle vorsortiert werden. Anhand der Grenzwerte, an denen sich die Farbe eines Balkens ändern soll, werden die Werte aufgeteilt. Balken mit 3 verschiedenen Farben brauchen logischerweise 2 Grenzwerte:
excel-diagramme-farblich-gestalten-nach-werten-beispiel-diagramm-vorbereiten
Das Vorsortieren läuft recht problemfrei über Formeln:
Für 2 Farben = 1 Grenzwert bei 75, angenommen in B2 steht der Quell-Wert:
Spalte 1: =WENN(B2>=75;B2;0)
Spalte 2: =WENN(B2<75;B2;0)
Für 3 Farben = 2 Grenzwert bei 75 und 55, angenommen in B2 steht der Quell-Wert:
Spalte 1: =WENN(B2>=75;B2;0)
Spalte 2: =WENN(UND(B2>=55;B2<75);B2;0)
Spalte 3: =WENN(B2<55;B2;0)
Für jeden weiteren Grenzwert wird eine weitere Spalte mit der Formel =WENN(UND(B2>=[Grenzwert];B2<[Grenzwert]);B2;0) nötig, es gibt also immer [Grenzwert+1] Spalten.
Anschließend können die Formeln einfach „nach unten gezogen“, also von Excels Autovervollständigung auf die restlichen Datenzeilen erweitert werden. Nun müsste die Tabelle so aussehen wie mein Beispiel oben.

Fertig: Werteabhängige farbige Excel-Diagrammbalken

Das Schwierigste ist überstanden. Nun noch die komplette Hilfstabelle (die zusätzlich erstellten Spalten inklusive Überschriften) markieren und über Einfügen -> Balkendiagramme eines der „gestapelten“ Diagramme auswählen. Excel wird bereits die Spalten unterschiedlich farblich darstellen, das kommt dem Ziel schon Nahe:
excel-diagramme-farblich-gestalten-nach-werten-beispiel-diagramm-auswaehlen
Anschließend können die farbigen Balken wie gewohnt über die Füllfarben wie gewünscht angepasst werden:
excel-diagramme-farblich-gestalten-nach-werten-beispiel-diagramm-farben-waehlen

via

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.