Internet mit Ubuntu-Linux unter VMWare Workstation

Ich bin gerade dabei zu Testzwecken Ubuntu 8.10 in VMWare Workstation einzurichten. Es soll später bestimmte Aufgaben und Tests für meine Arbeit in Angriff nehmen, wenn alles gut läuft.

Eine der wichtigsten Entscheidungen während der VM Einrichtung in VMWare ist ja die Auswahl des „Network Types“, also wie die Virtuelle Maschine mit Netzwerken interagieren wird. Hier gibt es mehrere Auswahlmöglichkeiten, von denen uns jetzt aber nur die ersten Beiden interessieren sollen:

vmware-network-typesbridged networking und network address translation (NAT) sind unsere Kandidaten für ein funktionierendes Internet. Der Unterschied ist folgender:
Bei bridged networking kann die VM eine eigene IP bekommen und als ein eigenständiger Client agieren. Bei NAT klinkt sich das Gastsystem beim Hostcomputer mit ein und nutzt seine Verbindung mit. Für den Fall ihr nutzt DHCP oder habt noch freie IPs für die manuelle Vergabe würde ich euch bridged networking empfehlen.

Nachdem die VM fertig eingestellt ist können wir die IP an das System vergeben.
ubuntu-ip-config

Nun kann es, wie bei mir auch, passieren, dass das Netzwerk trotz richtiger Einstellungen streikt. Pings funktionieren nur auf das Hostsystem und alles Andere ist unerreichbar. Netzwerkdiagnosen wie z.B. Pings, Traceroutes und Weiteres könnt ihr bei Ubuntu unter System->Systemverwaltung->Netzwerkdiagnose durchführen.
ubuntu-netzwerkdiagnose

2 Vorschläge:
1. Fahrt die VM herunter, klickt in der VMWare Übersicht eurer VM auf Network Adapter und aktiviert die Option „replicate physical network connection state“. Vor allem wenn ihr VMWare WS auf Laptops installiert, sollte dieses Häkchen gesetzt sein.
vmware-bridged-networking-option
2. Geht zu den Netzwerkeinstellungen (System->Einstellungen->Network Configuration), löscht das bestehende Network Interface und erstellt ein neues. Klickt auf Einstellungen und achtet bei der manuellen Vergabe darauf, dass ihr nach jeder Eingabe (IP, Maske, Gateway und DNS) die [ENTER] Taste drückt. Ich hatte manchmal das Problem, dass nach dem Schließen und erneutem Öffnen nicht alle eingetragenen Einstellungen übernommen wurden.
Überprüft durch erneutes Ansehen der Einstellungen, ob alles korrekt übernommen wurde.

Auch interessant:  Webseiten, Server und ganze Netzwerke mit der Enginsight Suite analysieren und überwachen (2018)

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.